Python 3.5 django and psycopg2


#1

מישהו יודע אם יש דרך לחבר את django עם postgreSQL
כאשר גרסת הפייתון היא 3.5
psycopg2 לא מותאם עדיין לגרסת 3.5
חרשתי המון באינטרנט ולא הצלחתי למצוא משהו
אשמח אם למישהו יש פתרון לבעייה הזאת


#2

הי!

כן,
ראשית שים לב אם יש לך התקנת פייתון 32bit או 64bit (כנראה 32) באמצעות הרצת הפקודה python.
אחרי שאתה יודע,
הדרך הארוכה היא להוריד באופן ידני wheel מכאן ולהתקינו עם pip:
http://www.lfd.uci.edu/~gohlke/pythonlibs/#psycopg

הדרך הקצרה, אם אתה סומך עלי, היא להריץ ישירות את הפקודה בעותק שהכנתי עבורכם:

pip install http://pkgs.10x.org.il/win32/psycopg2-2.6.1-cp35-none-win32.whl

אודה לך אם תאשר שזה עובד,
אודי


#3

עובד מעולה
חבל על השעות שחיפשתי פתרון
כמעט שעברתי לפייתון 2.7 :frowning:
תודה רבה רבה


#4

ודרך אגב, בזכותך:

אודי


#5

אודי, אתה ממליץ לעבור ל-3.5 או שלהשאר עם ה-2.7?


#6

הי!

כן, אני ממליץ על מעבר לפייתון 3 - ראה גם:

אודי


#7

מעולה. תודה.

2015-11-12 14:48 GMT+02:00 udioron info@hasadna.org.il: